Pale Moon 29.2.0 již nepodporuje starší rozšíření Firefoxu, která nejsou přenesena

Když Mozilla přešla ze svého staršího doplňkového systému na WebExtensions, vidlice Firefoxu, jako je Pale Moon, zaznamenaly nárůst uživatelů, kteří chtěli nadále používat rozšíření, která nový systém Mozilly již nepodporoval. Ne všechna rozšíření fungovala, ale mnohé ano a uživatelé mohli tato rozšíření nadále používat.

Vydání Pale Moon 29.2.0 zásadně mění kompatibilitu rozšíření prohlížeče, protože odstraňuje podporu starších rozšíření Firefoxu, která nejsou upravena tak, aby fungovala s prohlížečem Pale Moon. Pro Pale Moon je v současné době k dispozici asi 230 rozšíření oficiální webová stránka doplňků Pale Moon , včetně populárních rozšíření, jako jsou Decentraleyes, uBlock Origin (Legacy) nebo FoxyProxy.

Podle na příspěvek fóra od Moonchilda, vlastníka projektu Pale Moon, byla podpora pro rozšíření Firefoxu vývojovým týmem vždy považována za dočasnou. Klasická rozšíření Firefoxu se do Pale Moon nemusí vůbec instalovat nebo mohou představovat problémy s kompatibilitou, a to je jeden z hlavních důvodů blokování klasických rozšíření Firefoxu v Pale Moon 29.2.0.

kompatibilita doplňku pale moon 29.2.0

Rozšíření, která nejsou kompatibilní, mohou být přenesena, aby byla kompatibilní s prohlížečem Pale Moon, ale kdo to udělá? Pro projektový tým Pale Moon je odpověď jasná. Je to komunita, která musí posílit, aby zajistila, že rozšíření, která používají, zůstanou kompatibilní s prohlížečem. Realisticky většina uživatelů prohlížeče neví, jak vytvořit rozšíření prohlížeče nebo je upravit tak, aby fungovaly. Tým Pale Moon také nemůže do prohlížeče přenést většinu rozšíření prohlížeče, což ponechává malé skupině členů komunity dovednosti a čas přenést některá rozšíření do prohlížeče.

Vlákno je k dispozici na oficiálním fóru Pale Moon zveřejňovat kritická rozšíření pouze pro Firefox .

Uživatelé Pale Moon mohou dočasně zůstat ve verzi 29.1.1 prohlížeče, aby mohli nadále používat rozšíření, která by jinak byla v Pale Moon 29.2.0 nebo novější deaktivována. Dobrou možností, jak otestovat kompatibilitu, je použít přenosnou kopii Pale Moon 29.2.0 a otestovat kompatibilitu rozšíření v dané verzi, abyste zjistili, která z nainstalovaných rozšíření zůstávají kompatibilní a která ne. Přechod na starší verzi Pale Moon po instalaci upgradu 29.2.0 se nedoporučuje, protože může dojít k problémům s kompatibilitou profilu.

Pale Moon 29.2.0 byl vydán 27. dubna 2021 .

Teď ty : používáte Pale Moon? Ovlivňuje vás změna kompatibility?